Eclipse

From Bitpost wiki
Jump to: navigation, search
Eclipse Mars installation
We always want these: CDT, PDT, WTP (Web Tools Platform, includes JSTP for Javascript support)
  • Go to Eclipse Installer and install one of the big ones (avoid the installer)
    • PDT is good but there are instructions below to bolt on any of the three - so anything goes with your starting choice
  • install into development/eclipse folder (be careful not to install to eclipse/eclipse, if so just move and fix eclipse.ini)
  • Run and select this as the default workspace, do not prompt again: /home/m/development/eclipse-workspace
  • Install PDT
  • Install JavaScript
  • Install WTP
  • Install CDT
  • Close eclipse and update the settings folder to point to the common shared location (make sure the development/config repo is available)
    • Review the eclipse scripts to save/restore eclipse settings, it's nasty - keep looking for better ways to share settings across installations
    • use shared eclipse settings, to avoid problems like this.
cd ~/development/eclipse-workspace/.metadata/.plugins/org.eclipse.core.runtime/.settings
ln -fs /home/m/development/config/common/home/m/development/eclipse-workspace/.metadata/.plugins/org.eclipse.core.runtime/.settings/* .
  • Import all the existing projects that you need (A better Trader, Hang The DJ, etc.). You can import existing projects from ~/development, easy peasey!
  • Install the terminal plugin so you can run CI right in eclipse. Just drag the "install" button there to the eclipse toolbar.
  • To view/change customized keys:
Shift+Ctrl+j     customize keys even further!  :-)

Other things that might help:

  • Set up automatic refresh:
Preferences > General > Startup and shutdown > Refresh workspace on startup
Preferences > General > Workspace > Refresh automatically
  • put ~m/development/eclipse/eclipse.ini into config
Eclipse settings for all portable C++ boost projects
  • Set up .bashrc with my standard ENV vars for boost, c++ (and use notes there to build latest boost, if needed)
  • Set up build-Debug and build-Release folders via bootstrap force [debug|release], then configure build configurations for them both
  • Configure the project according to these Eclipse project configuration screenshots
Eclipse ToDo.txt macros
Set up two PracticallyMacro macros, tdw and tda.

tdw (ToDo: Go To Working)

Find: //      ^ DONE ^
  [x] case sensitive, search forward, wrap
Line Start
Move cursor down (x4) 

tda (ToDo: archive)

Move cursor right  (this ensures that the next backwards search gets just what we want)
Find: ^[^ \r\n]
  [x] reg expression
Line start
Find: .[\s\S]+?[\n\r]+[^ \r\n]
  [x] search forward, reg expression
Select Line Start
Cut
Find: //      ^ DONE ^
  [x] case sensitive
Line Start
Move cursor up
Paste
Move cursor down (x5)
Eclipse annoyances
  • To get problems to reset on build, I had to turn on (for all configs, then exit/restart): Project->Properties->C++ Build->Settings->Error Parsers-> [x] GNU gmake Error Parser 7
  • Click only ERRORS on Annotations dropdown arrow to bypass noise - I still can't get Ctrl-[,|.] to navigate errors, insanity
  • To set bookmarks in a file, you MUST open it via the Navigator / Project explorer. Drag/drop to IDE will disable bookmarking (doh!!).
eclipse java project layout format
Eclipse uses a workspace which holds projects. Java apps written with Eclipse are organized as follows:
  • Eclipse workspace (can also be the top version-control folder)
    • project folder (typically one "app" that you can "run")
      • package(s) (named something like "com.developer.project.application")
        • classes (each class is contained in one file)
eclipse new project from existing code
You can set up a new project without specifying anything about it, just to browse the code.
			File->New Project->Empty
			Name: bbby2e05
			Location: c:\
			[ ] Create subdir
			---
			Show all files
			select everything in include, rc->include in project
			repeat for src
			dont worry about mak or install folders for now, just add files later as needed
			save all
			---
			then set up a repo for it!
			cd c:\bbb2e05
			git init (plus add cpp c hpp h, commit, set up daily, sync on bitpost)
It is also possible to set up a C++ makefile or PHP project from existing code.
			(rclick projects area)->New->Project...->C++->Makefile Project with existing code
			(name it and make sure Show all files is selected)