This was going to be my naming standard for the foreseeable future.  But quicktype uses the same syntax for functionNames and variableNames, so we will go with that for code generated from quicktype.  Bye bye underscore, it’s been fun but I’m tired of typing_you_out_so_many_times.

So much lost time to such small things, but they can drive you mad if you don’t make a choice.  🙂

One Comment

  1. m says:

    And…. no. IMHO my code looks much less readable when there isn’t clear differentiation between

    * member and local variables
    * function names and variable names

    So I’m post-processing the quicktype output to add an underscore to its underscore-case convention. Only 800 search-and-replaces, what’s one more time around…

Leave a Reply