Software reference

From Bitpost wiki
Jump to: navigation, search

Kodi - Gimp - Audacity - Blender - LibreOffice

Mediawiki - Wordpress - Phabricator - Ampache - Discourse

CLion - Qt Creator - IDEA - Eclipse - juCi++ - Visual Studio Code

Atom - Emacs

i3 - UnixPorn - terminal - screen - albert

maim - copyq - ShareX

Steam - Tibia

sqlite - Robomongo - DBeaver - pgadmin3

weechat - Mconf - OpenMeetings - Hangouts - slack - AWWapp

Simon - Kaldi - Q2A

Chrome - Firefox - IceWeasel

Linux software raid - Wireshark - Apache

ssh - haproxy - cifs - sftp

vmware - virtualbox - x2go - Remote Desktop

OpenShift - CloudWatch

fail2ban


OS installation
Linux barebones quickstart
Ubuntu quickstart
Ubuntu upgrade / reinstall notes
Create and boot from Ubuntu USB
There should always be a boot USB for this in my set, but it needs recreation on new Ubuntu versions...
  1. Download the latest 64-bit Ubuntu desktop iso
  2. Format a USB drive as FAT (NOT exFAT or NTFS)
  3. Burn the iso to the USB, providing a GB of space (we want to add the nvidia driver once booted)
sudo usb-creator-gtk
  1. Boot with it
  2. On startup, select the USB EFI boot option in refind, select "Try Ubuntu", (on MBPro, hit e and add [ nouveau.noaccel=1] to grub line), hit F10 to start
  3. Once it is running, start System Settings, select Software, enable proprietary drivers
  4. Install, checking the [download as you go] and [install 3rd party stuff] boxes.
Ubuntu repo management
To see what repos Ubuntu is currently using:
cat /etc/apt/sources.list
Centos quickstart
Cygwin quickstart
Update gentoo kernel
Upgrade gentoo
Set up a new Pi in 10 minutes
The BEST thing to do is to copy the MicroSD from Carambola (marked with a black 'O'):
  • open a terminal so we can watch the MicroSD /dev/sd{#} assignments
sudo tail -f /var/log/syslog
  • take the carambola MicroSD card out of the Pi and put it into an Anker hub (gets less hot than the small MicroSD sleeves - and it WILL get hot!)
  • put another new MicroSD card into another Anker hub
  • open another terminal
dcfldd bs=4M if=/dev/sd{Letter of carambola} of=/dev/sd{Letter of new card}
  • They will get HOT... I don't know how to make sure they don't get TOO hot yet... cross your fingers I guess...
  • Drop the new card into the new Pi, boot
  • set up a new config folder
    • rm ~/config
    • cd development/config
    • cp -rp carambola lime && git add lime
    • cd ~ && ln -s development/config/lime config
  • change /etc/hostname
  • change name of exfat "share" partition
exfatlabel /dev/disk/by-label/carambola_share lime_share
  • edit /etc/fstab to update partition name
  • (optional) change the uuid of partitions as desired (otherwise you may get kernel/userspace warnings about conflicts when mounting more than one card in an ubuntu host) - note that I've never actually done this...
tune2fs /dev/sdaX -U random
  • reboot.. and away we go!
OS X
Raspberry Pi Raspbian setup
Set up OpenWRT on buffalo
   choices (3 is the only sensible!):
       1) hardcode all wan info and hope your network doesn't over-assign (this sucks)
       2) DCHP WAN, bridge lan so ports just become another switch
       3) DCHP WAN, serve up lan on different range than WAN
           this is AWESOME, you can immediately admin from anything that you hardwire up to the LAN ports
           set up a WAN static IP using WAN MAC if you can
           otherwise, to get WAN IP:
                   i can connect laptop to LAN port and get a 192.168.1 address on laptop from router DHCP
                   then i can connect PA LAN to router WAN port and get router IP from 
               
   steps:
       * reset buffalo as needed!
           it always starts with LAN DHCP support for 192.168.1 range, yeah baby
           wire laptop into LAN port and browse to 192.168.1.1
       * set up to get WAN IP via DHCP; make note of it using LAN connection: 192.168.50.57
       * Allow ssh from WAN IPs to router
           openwrt admin page->Network->Firewall->Traffic rules->"open ports on router"
               name: allow-wan-ssh
               Protocol: TCP+UDP
               external port: 22 (i could make it non-standard...)
               ADD
           then you can ssh to the WAN DHCP port, if you know it!  for now, it's: 
               ssh root@192.168.50.57
       * leave LAN support of 192.168.1 ON
           remember you can simply wire anything into LAN ports to get an address!
           and then you can browse to http://192.168.1.1 to admin the router
       ---
       now i can ssh to it from wallee (or anywhere on PA LAN)    
           ssh root@192.168.50.57  root/p*
       ---
       open https port too!  let's admin from wallee
       you have to open WAN port 443 in firewall config
       you also have to install support for this! 
           opkg update
           opkg install luci-ssl
           /etc/init.d/uhttpd restart
       but others have commented that this exposes your router and it WILL get hacked.  good point.
       skip for now
Windows 10 quickstart

Install Group Policy Editor from an admin Powershell console:

@echo off 
pushd "%~dp0" 

dir /b %SystemRoot%\servicing\Packages\Microsoft-Windows-GroupPolicy-ClientExtensions-Package~3*.mum >List.txt 
dir /b %SystemRoot%\servicing\Packages\Microsoft-Windows-GroupPolicy-ClientTools-Package~3*.mum >>List.txt 

for /f %%i in ('findstr /i . List.txt 2^>nul') do dism /online /norestart /add-package:"%SystemRoot%\servicing\Packages\%%i" 
pause

Run it and disable restarts:

Computer Configuration > Administrative Templates > Windows Components > Windows Update > Configure Automatic Updates
(o) Enabled
[2] Notify for download and auto install?  Or [3] Auto download and notify for install?  Going with [3], we'll see.
(or...) (o) Enabled: No auto-restart with logged on users for scheduled automatic updates installations
(reboot) 
OpenELEC multi-boot install
The easiest way is to add a new drive just for OpenElec and install OpenElec to it with the installer. But if you want to SHARE ONE DRIVE with other boots, DO NOT DO THAT :-) Do this instead:
  • On an existing refind-booted system, set up two new ext4 partitions
    • one about 2GB in size, labeled [SYSTEM], and marked as bootable
    • the other with 10GB or more, labeled [STORAGE]
    • prep the drives (no journal, ssd trim)
  • download openelec and mount; there are a couple ways:
    • get the img and install to a thumb
    • get the img and mount (see below)
  • Set up OE drives to mount in other OSes to /openelec-system and /openelec-storage
/dev/disk/by-label/SYSTEM  /openelec-system  ext4 noatime 0 0
/dev/disk/by-label/STORAGE /openelec-storage ext4 noatime 0 0
  • copy target/KERNEL and target/SYSTEM to SYSTEM
cp OpenELEC_img/target/KERNEL /openelec-system/
cp OpenELEC_img/target/SYSTEM /openelec-system/
  • set up UEFI boot
    • subl /boot/efi/EFI/refind/refind.conf (and add this block)
# MDM Trying this, from: http://openelec.tv/forum/64-installation/70783-how-to-efi-booting-openelec-on-new-pc-s-nuc-s
# Only I had to change BOOT to SYSTEM.  and quiet to debugging.
menuentry OpenELEC {
	  icon EFI/refind/icons/os_openelec.png
	  volume SYSTEM
	  ostype Linux
	  loader KERNEL
#	  options "boot=LABEL=SYSTEM disk=LABEL=STORAGE debugging"
	  options "boot=LABEL=SYSTEM disk=LABEL=STORAGE quiet"
}
  • I THINK you need one or more of these too, not sure!
cp target/boot/bootx64.efi /openelec-system/BOOT
cp target/boot/bootx64.efi /boot/efi/EFI/ubuntu/
cp target/boot/bootx64.efi /boot/efi/EFI/ubuntu/
OpenELEC boot from thumb
NOTE: I have the image already on a white stick with red lettering... anyway...
  • Get the latest dev version (stable didn't work for me although this may change)
  • dd it onto a thumb
  • reboot and select to boot to the thumb in BIOS
  • when the boot: line comes up, type "live" to get run a live Kodi rather than run the crufty old installer
Cloud and AWS tasks
AWS clone
  1. create a snapshot of an instance
  2. create an instance of a snapshot

Example...

   instances -> pa-jenkins-win-test -> right-click, Create Image -> 
       { 
           name: pa-jenkins-win-test, 
           AMI ID: ami-57cadc3d
       }
   This creates a new "AMI Image"- WARNING: The source machine will be rebooted!
   monitoring it, waiting for it to be ready... ready.  man that took a while.  
   Select AMI -> rightclick -> Launch...
       instance type: t2.medium (same as original; 2 vCPUs, 4GB mem)
       config: SELECT THE SAME SUBNET (us-east-1d) so on the same LAN and can ping each other; (all other defaults)
       storage: (default)
       tag instance: { name: "pa-jenkins-win-test-older" }
       security: select existing { "pa-shared immed_inno_group raleigh-windows-dev" } (as per Brad, previously - note that "raleigh" is no longer available) 
       LAUNCH
       ---
       select an existing key pair or create a new pair
           let's use the existing ones since this is a shared resource
           2014Dec25_air.pem (it's in my docs repo)
       ----
       monitor it, wait for it to be created...
       because it was cloned from a machine that had the password changed, you can't use the existing key to regenerate
       i didn't realize it was changed??
       anyway, it should be the exact same way to connect to test, but with a diff ip/hostname (*-older)
       yep.  switched IP to 172.30.3.208 and it's good to go!
Expand AWS storage
   stop instance
   in instance details, right-click the block device link (typically /dev/sd1)
   click the EBS ID
   snapshot the volume, wait for it to get to "complete"
   right-click snapshot, create volume
       use the same availability zone: us-east-1d
   on the volume created screen, click to show the volume
       vol-b88c3c45
   get the orig volume:
       vol-5af8f0a0
       https://console.aws.amazon.com/ec2/v2/home?region=us-east-1#Volumes:search=vol-5af8f0a0;sort=size
   type this into volume filter to see them both:
       vol-b88c3c45|vol-5af8f0a0
   make note of the attachment info for the old 30GB drive:
       Attachment information
       i-ad45941d (pa-jenkins-win-test):/dev/sda1 (attached)
   detach the volume!  holy cow.  
       i thought about restarting the instance and shutting it down first...
       but i think stopping it already did that!  MOVE ON    
   right click new volume, "attach volume"
       start typing instance name (pa-jenkins-win-test worked)
       CHANGE TEH SELECTED DRIVE NAME (xsdf or something) to the original!  /dev/sda1
       geez that's scary, wonder if it will work...
       YEP!!!  AW#ESOMENWESSSS##$$
   type "disk management", right-click the 30gb image, select Extend
   DONE!!!
Ubuntu set up networking
Install NetworkManager, as the wpagui UI sucks
  • sudo apt-get install network-manager-gnome
  • YOU MUST remove interfaces from /etc/network/interfaces so wpa gives them up to nm-applet
  • add nm-applet to startup if needed - i don't think it is needed as it seems to start up automatically now - try rebooting first

Old

Clonezilla - Synaptic

CodeLite - Brackets - Sublime - Scite -

Hipchat - TeamSpeak - Cisco Spark - Blink